Issues loading the MindTickle platform
Incident Report for Mindtickle, Inc.
Postmortem

As part of our theme of Jan and Feb to have 10x scale readiness, we have been performing capacity planning and load testing to optimize our applications. Usually, these things are performed in a controlled environment and do not impact the production environment. In this case, one of our services had a loose end for 10x scaling. We have identified a couple of bottlenecks in that service and are taking steps to optimize this.

On a typical day, this will not be a concern even with a peak load, and the platform will function as expected.

Posted Jan 15, 2022 - 02:18 PST

Resolved
This incident has been resolved.
Posted Jan 15, 2022 - 01:04 PST
Investigating
We are currently investigating this issue.
Posted Jan 15, 2022 - 00:55 PST
This incident affected: Mindtickle Platform, Operational (Login, User Sync, Rule Automation, Notifications), Analytics (In-Platform Analytics, Reporting API), Practice and Execution (Mission, Coaching Sessions, Call AI), Knowledge (Course / Quick-Update / Assessment, Instructor-Led Training, Spaced Reinforcement), and Interface (Admin Site, Learning Site, Mobile App).