Two-Way Roleplay Service Disruption

Incident Report for MindTickle, Inc.

Identified

We have identified the root cause as a service disruption at a third-party provider that powers parts of the Two-Way Roleplay workflow.

We are actively working with the vendor to restore the service and recover impacted functionality as quickly as possible.
Posted May 21, 2026 - 08:59 PDT

Investigating

Users may experience issues starting Two-Way Roleplay sessions. In addition admins may be unable to preview roleplays.

The team is actively investigating the issue and working toward resolution.
Posted May 21, 2026 - 08:29 PDT
This incident affects: Practice and Execution (Mission).