Call AI Service Outage

Incident Report for MindTickle, Inc.

Resolved

The issue has now been identified and resolved, and Call AI services are operating normally again.

We will share a detailed Root Cause Analysis (RCA) shortly.
Posted May 11, 2026 - 09:35 PDT

Investigating

We are currently investigating an issue impacting call recordings in Call AI. Users may experience failures while recording calls.
The team is actively working on identifying the root cause and restoring normal functionality.
Further updates will be shared shortly.
Posted May 11, 2026 - 07:25 PDT
This incident affected: Practice and Execution (Call AI).