Some analytics reports may serve stale data.

Incident Report for MindTickle, Inc.

Resolved

This issue is resolved. All affected reports are now showing current data. Thank you for your patience.
Posted Aug 19, 2026 - 19:07 PDT

Investigating

We're investigating an issue where a subset of customers may see stale data in certain analytics reports, specifically: SSR, Custom Dashboards, Manager & Relationship reports, and Overview / Adoption / Performance reports. Other reports and product areas are unaffected. If your analytics reflect current data, no action is needed. We'll post an update shortly.
Posted Aug 19, 2026 - 10:16 PDT
This incident affected: Analytics (In-Platform Analytics).