Issues logging into the platform
Incident Report for MindTickle, Inc.
Postmortem

We have performed the root cause analysis of the incident as part of the long-term resolution of incident management.

Impact:

  • Users were not able to log in to the platform between 3:45 PM to 4:10 PM IST. This did not impact the users who were already logged in.

Root Cause Analysis:

  • We identified that users were not able to log in to the platform due to an issue with our login provider. Login provider is a component used to retrieve the login methods configured and enabled for a customer.
  • In a recent code deployment, a different version of the login provider was promoted to the production environment. This build was not compatible with the currently deployed dependent services and hence, was not able to retrieve the login methods required to display the login page.

Actions Taken:

  • As an immediate action, we promoted a correct version of the login provider component which was compatible with the dependent services and the login page started working correctly.
  • As part of the preventive actions, we are adding further checkpoints into our existing build and deploy verification process to avoid similar scenarios in the future.
Posted Jul 07, 2021 - 03:41 PDT

Resolved
This incident has been resolved.
Posted Jul 06, 2021 - 03:41 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 06, 2021 - 03:40 PDT
Identified
The issue has been identified and a fix is being implemented. This has impacted only the login functionality of the learning and admin site. No impact on the users already logged into the platform.
Posted Jul 06, 2021 - 03:40 PDT
Investigating
We are currently investigating the issue.
Posted Jul 06, 2021 - 03:36 PDT
This incident affected: Operational (Login).