'Featured Hubs' widget is not loading across the Mindtickle platform

Incident Report for MindTickle, Inc.

Resolved

This incident has been resolved. The 'Featured Hubs' widget is now loading as expected, and the Mindtickle platform is fully operational.
Posted May 18, 2026 - 06:55 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 18, 2026 - 06:31 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 18, 2026 - 06:21 PDT

Investigating

The 'Featured Hubs' widget, wherever used on the Mindtickle platform, is not loading. The Hubs and individual media/assets are working properly. We are currently investigating this.

All other capabilities of the Mindtickle platform are operating normally.
Posted May 18, 2026 - 06:17 PDT
This incident affected: Mindtickle Platform and Content Management (Asset Hub).