Call AI bot unable to join calls

Incident Report for MindTickle, Inc.

Postmortem

We experienced a service disruption impacting Call AI bot functionality. During this time, select scheduled meetings were affected, where Call AI bots were unable to join and record.

The issue has been fully resolved, and services have returned to normal operation.

Impact

  • Call AI bots were unable to join select scheduled meetings
  • Call recordings and transcriptions were not generated for impacted meetings

Timeline

  • 07:50 AM PT: Incident began; bots unable to join select meetings
  • 07:52 AM PT: Alerts triggered; issue detected and investigation initiated
  • 09:00 AM PT: Root cause identified within Call AI bot infrastructure
  • 10:15 AM PT: Mitigation measures applied; service recovery in progress
  • 11:25 AM PT: Service fully restored; bots resumed normal operation

Root Cause

This incident was caused by a transient issue within the Call AI bot infrastructure, which impacted service availability during the affected period.

Next Steps

  • Exploring & implement enhanced failover mechanisms to improve system resilience
  • Introducing more granular monitoring and alerting for faster detection

We apologize for the inconvenience caused and appreciate your patience.

Posted Mar 26, 2026 - 20:54 PDT

Resolved

Between 07:50 AM and 11:25 AM PT on March 24, 2026, the Mindtickle platform experienced a service disruption affecting Call Recordings. Full service was restored by 11:25 AM PT. We are currently conducting a thorough investigation and will publish a detailed Root Cause Analysis (RCA) shortly.
Posted Mar 24, 2026 - 08:00 PDT