Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 14, 2024 - 03:30 PST
Scheduled
Please be advised that the MindTickle platform will be unavailable from 03:30 am to 08:30 am on Saturday, December 14th, 2024.
We apologise for the inconvenience that this may cause. Kindly reach out to us at support@mindtickle.com for any concerns that you may have about the planned outage.
Posted Nov 21, 2024 - 02:51 PST
This scheduled maintenance affected: Knowledge (Course / Quick-Update / Assessment, Instructor-Led Training, Spaced Reinforcement), Practice and Execution (Mission, Coaching Sessions, Call AI), Analytics (In-Platform Analytics, Reporting API), Operational (Login, User Sync, Rule Automation, Notifications), Mindtickle Platform, Interface (Admin Site, Learning Site, Mobile App), Content Management (Content Center, Asset Hub, Digital Sales Rooms (DSR)), and Mindtickle Copilot (Mindtickle Copilot).