Learning site, admin site and mobile applications are unavailable
Incident Report for Mindtickle, Inc.
Postmortem

We have performed the root cause analysis of the incident as part of our incident review and postmortem process.

Impact:

  • Users were not able to access the MindTickle platform, including admin and learning sites.

Root Cause Analysis:

  • On Jan 7, 2021, at 8:26 PM PST, users started facing challenges accessing the MindTickle platform.
  • In our initial analysis, we identified that our systems were unable to fetch the settings required to load the landing page of the learning site and admin site.
  • After a detailed analysis, we found that the settings were inaccessible due to a conflict in versioning introduced in a recent deployment.

Actions Taken:

  • As an immediate action, we initiated the restoration from the last full backup to ensure the majority of platform components were up and running at the earliest.
  • As a next step, we started restoring the incremental backups to the current version. This completed the settings restoration process and resolved the issue.
Posted Jan 08, 2021 - 07:43 PST

Resolved
The incident has been resolved. All the learning sites, admin site and mobile applications are operating normally. Please reach out to MindTickle support team at support @mindtickle.com if you face any challenges.
Posted Jan 07, 2021 - 23:21 PST
Update
The system restoration activity is still in progress and we expect it to be completed in the next 45 minutes. We will keep you updated on the progress.
Posted Jan 07, 2021 - 22:05 PST
Monitoring
We have identified the issue and we are in the process of restoring the systems. Many of the things are already up now. We will post an update once the restoration activity is complete.
Posted Jan 07, 2021 - 21:36 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 07, 2021 - 21:21 PST
Investigating
MindTickle platform, including the learning site, admin site, and mobile applications are currently down and users won't be able to access the platform. We are currently investigating the issue and will post an update as soon as we have more information.
Posted Jan 07, 2021 - 20:47 PST
This incident affected: Operational (Login, User Sync, Notifications), Analytics (In-Platform Analytics, Reporting API), Practice and Execution (Mission, Coaching Sessions), Knowledge (Course / Quick-Update / Assessment, Instructor-Led Training), and Interface (Mobile App).