Elevated Error Rate on the Mindtickle Platform

Incident Report for MindTickle, Inc.

Monitoring

Mitigation has been deployed and services are operating normally. We are continuing to monitor the platform closely to ensure stability.
Posted Jun 12, 2026 - 18:01 PDT

Identified

We have identified the cause of the elevated error rates and are deploying mitigation measures. We are monitoring the platform closely and working to restore normal service.
Posted Jun 12, 2026 - 17:51 PDT

Investigating

We are currently experiencing a partial service disruption on Mindtickle platform. Users may encounter errors, intermittent failures, or degraded performance across the platform. Our engineering team is actively investigating and mitigating the issue while closely monitoring recovery efforts.
Posted Jun 12, 2026 - 17:35 PDT
This incident affects: Knowledge (Course / Quick-Update / Assessment, Instructor-Led Training, Spaced Reinforcement), Practice and Execution (Mission, Coaching Sessions, Call AI), Analytics (In-Platform Analytics, Reporting API), Operational (Login, User Sync, Rule Automation, Notifications), Mindtickle Platform, Content Management (Content Center, Asset Hub, Digital Sales Rooms (DSR)), and Mindtickle Copilot (Mindtickle Copilot).