[Resolved] Intermittent Content Upload Failures Impacting Admins for a Subset of Customers

Incident Report for MindTickle, Inc.

Resolved

[Resolved]

A subset of customers (admins only) experienced intermittent failures when admins attempted to upload content to the platform. End users were not impacted and were able to view existing content without issues. The issue has been resolved, and all admin content upload workflows are operating as expected.

Incident Timeline

Start Time: 05 Feb 2026, 11:15 PM PT

Resolved Time: 06 Feb 2026, 05:12 AM PT

We will share a detailed RCA once the post-incident review is complete.
Posted Feb 05, 2026 - 23:15 PST