Issues loading coaching and mission modules
Incident Report for MindTickle, Inc.
Postmortem

We have performed the root cause analysis of the incident as part of the long-term resolution of incident management.

Impact

  • Learners were facing issues loading coaching and mission modules in the learning site.

Root Cause Analysis

  • During our planned downtime, we migrated the coaching applications database from a self-managed MySQL instance to the AWS-managed RDS service.
  • After the data migration, the database instances could not start due to a bug in the specific version of MySQL used by AWS RDS.

Actions Taken

  • Following AWS Support Team’s recommendation to resolve the bug, we upgraded the MySQL used by the AWS RDS to a newer version in which the bug was resolved.
  • After the MySQL version upgrade, the database instances were up and coaching applications started loading normally.
  • As part of the preventive actions, we have added necessary checks in our migration process to ensure we identify such bugs during our dry run migration activity.
Posted Jun 21, 2021 - 22:04 PDT

Resolved
The incident has been resolved. Learners will be able to load coaching and mission modules without any issues. Please reach out to the support team at support@mindtickle.com in case of any queries.
Posted Jun 19, 2021 - 13:08 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 19, 2021 - 13:03 PDT
Investigating
We are currently investigating this issue. Learners are facing issues loading coaching and mission modules.
Posted Jun 19, 2021 - 12:50 PDT
This incident affected: Practice and Execution (Mission, Coaching Sessions).