Mindtickle is experiencing a partial outage — some users may be unable to access the platform.

Incident Report for MindTickle, Inc.

Resolved

This incident has been resolved, we will publish a detail root cause analysis soon.
Posted May 21, 2025 - 23:44 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 21, 2025 - 23:34 PDT

Investigating

Our team is actively investigating the issue and working to restore full access as quickly as possible.
Posted May 21, 2025 - 23:10 PDT
This incident affected: Knowledge (Course / Quick-Update / Assessment, Instructor-Led Training, Spaced Reinforcement), Practice and Execution (Mission, Coaching Sessions, Call AI), Analytics (In-Platform Analytics, Reporting API), Operational (Login, User Sync, Rule Automation, Notifications), Mindtickle Platform, Interface (Admin Site, Learning Site, Mobile App), Content Management (Content Center, Asset Hub, Digital Sales Rooms (DSR)), and Mindtickle Copilot (Mindtickle Copilot).