High Error Rates in Seller Copilot

Incident Report for MindTickle, Inc.

Resolved

The incident has been resolved, and all systems are now operational.
Posted Aug 31, 2026 - 06:06 PDT

Monitoring

a fix has been implemented and we are monitoring the situation.
Posted Aug 31, 2026 - 05:10 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 31, 2026 - 04:40 PDT

Investigating

Seller Copilot is experiencing high error rates due to a downstream outage in the Azure data center supporting this use case. Also, Mindtickle chat support may experience failures in generating responses to your queries.
Posted Aug 31, 2026 - 04:08 PDT
This incident affected: Mindtickle Copilot (Mindtickle Copilot).