Users Unable to Log In to Mindtickle Platform

Incident Report for MindTickle, Inc.

Resolved

The login issue affecting the platform has been resolved, and users can now sign in normally. The disruption lasted from 04:52 AM PT to 9:42 AM PT.

No customer data was affected. Users who were already logged in to Mindtickle were able to access the platform without any concerns.

We're sorry for the disruption this caused. If you're still unable to log in, please contact us @ mtsupport@mindtickle.com.

We'll complete an internal postmortem and publish the RCA here within the next few days.
Posted Sep 21, 2026 - 09:42 PDT

Update

Update: Login functionality has now been restored for the majority of users. We will continue to monitor the platform closely to ensure full recovery and stability.
Posted Sep 21, 2026 - 08:46 PDT

Monitoring

We are seeing signs of recovery, and some users should now be able to log in to the Mindtickle platform. We are continuing to monitor the recovery and work through the remaining impacted users.
Posted Sep 21, 2026 - 08:10 PDT

Identified

We have identified the root cause of the login issue and are currently working on a patch.
Posted Sep 21, 2026 - 06:53 PDT

Investigating

Users are currently unable to log in to the Mindtickle platform. Users who are already logged in are not impacted and can continue using the platform. Our team is actively investigating the issue.
Posted Sep 21, 2026 - 06:13 PDT
This incident affected: Operational (Login).